@ Карта сайта News Автора!

Bog BOS: IOS: Лабораторные работы

Последние изменения:
2017.04.19: hard: АВР от APC

Последнее изменение текста: 19980626
Скопировано с www.bog.pp.ru: 2017.04.30

Bog BOS: IOS: Лабораторные работы

  1. Основы построения сетей
    1. Введение в TCP/IP
      1. основы маршрутизации
      2. основы настройки маршрутизаторов
      3. лабораторная работа
    2. введение в сетевые среды
      1. HDLC, PPP
      2. Ethernet
      3. Frame Relay
    3. настройка в маршрутизаторах CISCO выделенных синхронных и асинхронных каналов и каналов Ethernet
      1. лабораторная работа
    4. средства диагностики работы маршрутизаторов CISCO
      1. лабораторная работа
    5. самостоятельные занятия под наблюдением преподавателя
  2. управление сложными сетями (часть 1)
    1. ограничение трафика и обеспечение безопасности сети
      1. настройка access-list'ов
      2. лабораторная работа
    2. настройка приоритетов различных видов трафика на выделенных каналах
      1. настройка различных видов очередей (priority queues, custom queues и т.д.)
      2. лабораторная работа
    3. минимизация служебного трафика
      1. обзор протоколов динамической маршрутизации, EIGRP
      2. route aggregation
      3. лабораторная работа
    4. самостоятельные занятия под наблюдением преподавателя
  3. управление сложными сетями (часть 2)
    1. управление удаленным доступом
      1. Dial-on-demand routing
      2. авторизация и протоколирование (AAA)
      3. виртуальные наложенные сети
      4. лабораторная работа
    2. угрозы безопасности сети (краткий обзор)
    3. протокол OSPF
      1. лабораторная работа
    4. самостоятельные занятия под наблюдением преподавателя
  4. управление сложными сетями (часть 3)
    1. протокол BGP4
      1. лабораторная работа
    2. policy routing
      1. лабораторная работа
    3. туннели GRE
      1. лабораторная работа
    4. самостоятельные занятия под наблюдением преподавателя
  5. обзор оборудования CISCO
    1. маршрутизаторы
    2. средства обеспечения удаленного доступа
    3. Firewall'ы
    4. мультиплексоры голос/данные
    5. вручение дипломов


Лабораторная работа: основы настройки маршрутизаторов

Используемый стенд: стенд 1.
Предварительные действия:

  1. подключаем консольный провод от соответствующего маршрутизатора к порту COM2
  2. запускаем и настраиваем TELEMATE
  3. включаем свой маршрутизатор
  4. если в нем уже была какая-то настройка, то стираем ее:

    enable
    erase start
    reload

  5. отказываемся от автоматической настройки

настройка Frame Relay switch (c2522)

Действия по шагам:

  1. войти в режим администратора
    Router>enable
  2. начать конфигурирование с терминала═

    Router#configure terminal

  3. задать имя хоста

    Router(config)#hostname c2522

  4. задать защищенный пароль администратора

    c2522(config)#enable secret cisco

  5. понадобится в дальнейшем

    c2522(config)#ip subnet-zero
    c2522(config)#ip classless

  6. отключаем DNS

    c2522(config)#no ip domain-lookup

  7. временная зона и летнее время

    c2522(config)#clock timezone MSK 3
    c2522(config)#clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00

  8. закрываем вход на все терминальные линии (консоль, вспомогательный порт, виртуальные терминалы)

    c2522(config)#line console 0
    c2522(config-line)#password cisco
    c2522(config-line)#login
    c2522(config-line)#no exec-timeout
    c2522(config-line)#exit
    c2522(config)#line aux 0
    c2522(config-line)#password cisco
    c2522(config-line)#login
    c2522(config-line)#no exec-timeout
    c2522(config-line)#exit
    c2522(config)#line vty 0 4
    c2522(config-line)#password cisco
    c2522(config-line)#login
    c2522(config-line)#no exec-timeout
    c2522(config-line)#exit

  9. выход из режима конфигурирования и═ сохранение конфигурации═

    c2522(config)#exit
    c2522#copy running-config startup-config

Получившаяся конфигурация (show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2522
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
ip subnet-zero
no ip domain-lookup
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Ethernet0
═no ip address
═shutdown
!
interface Serial...
═no ip address
═shutdown
!
!
interface BRI0
═no ip address
═shutdown
!
ip classless
!
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end

настройка маршрутизатора a, b и c

Действия по шагам:

  1. войти в режим администратора

    Router>enable

  2. начать конфигурирование с терминала

    Router#configure terminal

  3. задать имя хоста

    Router(config)#hostname c2500x

  4. задать защищенный пароль администратора

    c2500x(config)#enable secret cisco

  5. понадобится в дальнейшем

    c2500x(config)#ip subnet-zero
    c2500x(config)#ip classless

  6. отключаем DNS

    c2500x(config)#no ip domain-lookup

  7. временная зона и летнее время

    c2500x(config)#clock timezone MSK 3
    c2500x(config)#clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00

  8. закрываем вход на все терминальные линии (консоль, вспомогательный порт, виртуальные терминалы)

    c2500x(config)#line console 0
    c2500x(config-line)#password cisco
    c2500x(config-line)#login
    c2500x(config-line)#no exec-timeout
    c2500x(config-line)#exit
    c2500x(config)#line 1 8 (или 16)
    c2500x(config-line)#password cisco
    c2500x(config-line)#login
    c2500x(config-line)#no exec-timeout
    c2500x(config-line)#exit
    c2500x(config)#line aux 0
    c2500x(config-line)#password cisco
    c2500x(config-line)#login
    c2500x(config-line)#no exec-timeout
    c2500x(config-line)#exit
    c2500x(config)#line vty 0 4
    c2500x(config-line)#password cisco
    c2500x(config-line)#login
    c2500x(config-line)#no exec-timeout
    c2500x(config-line)#exit

  9. выход из режима конфигурирования и═ сохранение конфигурации


    c2500x(config)#exit
    c2500x#copy running-config startup-config

Получившаяся конфигурация (show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500x
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
ip subnet-zero
no ip domain-lookup
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Ethernet0
═no ip address
═shutdown
!
interface Serial...
═no ip address
═shutdown
!
ip classless
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 8
═exec-timeout 0 0
═password cisco
═login
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end


Лабораторная работа: настройка интерфейсов loopback, ethernet и frame relay

Используемый стенд: стенд 1.
Используется конфигурация из лабораторной работы 1.1.3.

настройка Frame Relay switch (c2522)

Действия по шагам:

  1. начать конфигурирование с терминала═

    Router#configure terminal

  2. задать, что данный маршрутизатор будет служить коммутатором Frame Relay

    c2522(config)#frame-relay switching

  3. конфигурируем последовательный интерфейс 0

    c2522(config)#interface serial 0

  4. задаем протокол Frame Relay на данном интерфейсе

    c2522(config-if)#encapsulation frame-relay

  5. задаем ansi протокол управления соединением

    c2522(config-if)#frame-relay lmi-type ansi

  6. интерфейс является "задающим"

    c2522(config-if)#frame-relay intf-type dce
    c2522(config-if)#clock rate 2000000

  7. коммутация между интерфейсами

    c2522(config-if)#frame-relay route 31 interface serial 1 34

  8. активация интерфейса

    c2522(config-if)#no shutdown
    c2522(config-if)#exit

  9. аналогично для интерфейса serial 1

    c2522(config)#interface serial 1
    c2522(config-if)#encapsulation frame-relay
    c2522(config-if)#frame-relay lmi-type ansi
    c2522(config-if)#frame-relay intf-type dce
    c2522(config-if)#clock rate 2000000
    c2522(config-if)#frame-relay route 34 interface serial 0 31
    c2522(config-if)#no shutdown
    c2522(config-if)#exit

  10. выход из режима конфигурирования и═ сохранение конфигурации

    c2522(config)#exit
    c2522#copy running-config startup-config

Получившаяся конфигурация (show run):

Current configuration:
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2522
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Ethernet0
═no ip address
═shutdown
!
interface Serial0
═no ip address
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay route 31 interface Serial1 34
!
interface Serial1
═no ip address
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay route 34 interface Serial0 31
!
interface Serial...
═no ip address
═shutdown
!
!
interface BRI0
═no ip address
═shutdown
!
ip classless
!
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end

настройка маршрутизатора a, b и c

Действия по шагам (вместо n и m должны быть соответствующие числа):

  1. начать конфигурирование с терминала

    c2500x#configure terminal

  2. для c2500b задать, что данный маршрутизатор будет служить коммутатором Frame Relay

    c2500b(config)#frame-relay switching

  3. настраиваем Ethernet

    c2500x(config)#interface ethernet 0
    c2500x(config-if)#ip address 10.127.n.1 255.255.255.0
    c2500x(config-if)#no shutdown
    c2500x(config-if)#exit

  4. настраиваем loopback

    c2500x(config)#interface loopback 0
    c2500x(config-if)#ip address 10.128.n.1 255.255.255.255
    c2500x(config-if)#no shutdown
    c2500x(config-if)#exit

  5. настраиваем frame relay

    c2500x(config)#interface serial 0
    c2500x(config-if)#ip address 10.127.10.n 255.255.255.252
    c2500x(config-if)#encapsulation frame-relay

  6. задаем ansi протокол управления соединением

    c2500x(config-if)#frame-relay lmi-type ansi

  7. для c2500b интерфейс является "задающим"

    c2500b(config-if)#frame-relay intf-type dce
    c2500b(config-if)#clock rate 2000000

  8. задаем соответствие между DLCI и IP адресом соседа

    c2500x(config-if)#frame-relay map ip 10.127.10.n m broadcast

  9. задаем DLCI

    c2500x(config-if)#frame-relay interface-dlci m
    c2500x(config-fr-dlci)#exit

  10. активация интерфейса

    c2500x(config)#interface serial 0
    c2500x(config-if)#no shutdown
    c2500x(config-if)#exit

  11. аналогично для второго интерфейса

    c2500x(config)#interface serial 1
    c2500x(config-if)#ip address 10.127.10.n 255.255.255.252
    c2500x(config-if)#encapsulation frame-relay

  12. задаем ansi протокол управления соединением

    c2500x(config-if)#frame-relay lmi-type ansi

  13. для c2500b интерфейс является "задающим"

    c2500b(config-if)#frame-relay intf-type dce
    c2500b(config-if)#clock rate 2000000

  14. задаем соответствие между DLCI и IP адресом соседа

    c2500x(config-if)#frame-relay map ip 10.127.10.n m broadcast

  15. задаем DLCI

    c2500x(config-if)#frame-relay interface-dlci m
    c2500x(config-fr-dlci)#exit

  16. активация интерфейса

    c2500x(config)#interface serial 1
    c2500x(config-if)#no shutdown
    c2500x(config-if)#exit

  17. статическая маршрутизация

    c2500x(config)#ip route 10.128.n.1 255.255.255.255 10.127.10.m
    c2500x(config)#ip route 10.128.k.1 255.255.255.255 10.127.10.l
    c2500x(config)#ip route 10.127.10.i 255.255.255.252 10.127.10.j
    c2500x(config)#ip route 10.127.n.0 255.255.255.0 10.127.10.m
    c2500x(config)#ip route 10.127.k.0 255.255.255.0 10.127.10.l

  18. выход из режима конфигурирования и═ сохранение конфигурации

    c2500x(config)#exit
    c2500x#copy running-config startup-config

Получившаяся конфигурация (show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
ip classless
ip route 10.128.0.1 255.255.255.255 10.127.10.13
ip route 10.128.1.1 255.255.255.255 10.127.10.10
ip route 10.127.10.0 255.255.255.252 10.127.10.13
ip route 10.127.10.0 255.255.255.252 10.127.10.10
ip route 10.127.0.0 255.255.255.0 10.127.10.13
ip route 10.127.1.0 255.255.255.0 10.127.10.10
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 8
═exec-timeout 0 0
═password cisco
═login
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end


Лабораторная работа: средства диагностики

Используемый стенд: стенд 1.
Основные используемые команды:

Упражнение 1: на каждом маршрутизаторе "уронить" один последовательный интерфейс (shutdown). Соседи должны определиыь, какой именно интерфейс был выключен.
Упражнение 2: привести все в порядок. Выключить коммутатор Frame Relay (c2522). Перестроить таблицы маршрутизации так, чтобы сеть оставалась связной.


Лабораторная работа: настройка ACL

Используемый стенд: стенд 1.
Используется конфигурация из лабораторной работы 1.3.1.
Упражнение: закрыть доступ по telnet в "свою" подсеть, за исключением доступа с персоналок.
Действия по шагам (вместо n и m должны быть соответствующие числа):

  1. начать конфигурирование с терминала


    c2500x#configure terminal

  2. закрыться от подделки локальных адресов


    c2500x(config)#access-list 101 deny ip 10.127.n.0 0.0.0.255 any
    c2500x(config)#access-list 101 deny ip 10.128.n.0 0.0.0.255 any
    c2500x(config)#access-list 101 deny ip 10.127.10.k 0.0.0.3 any
    c2500x(config)#access-list 101 deny ip 10.127.10.m 0.0.0.3 any

  3. разрешить доступ telnet с персоналок


    c2500x(config)#access-list 101 permit tcp 10.127.0.2 0.0.255.0 any eq telnet

  4. запретить доступ по telnet с остальных мест


    c2500x(config)#access-list 101 deny tcp any any eq telnet

  5. разрешить все остальное


    c2500x(config)#access-list 101 permit any any

  6. применить построенный список доступа на входе serial 0 и serial 1


    c2500x(config)#interface serial 0
    c2500x(config-if)#ip access-group 101 in
    c2500x(config-if)#exit
    c2500x(config)#interface serial 1
    c2500x(config-if)#ip access-group 101 in
    c2500x(config-if)#exit
    c2500x(config)#exit
    c2500x#

Получившаяся конфигурация, изменения выделены (show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
ip access-group 101 in
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
ip access-group 101 in
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
ip classless
ip route 10.128.0.1 255.255.255.255 10.127.10.13
ip route 10.128.1.1 255.255.255.255 10.127.10.10
ip route 10.127.10.0 255.255.255.252 10.127.10.13
ip route 10.127.10.0 255.255.255.252 10.127.10.10
ip route 10.127.0.0 255.255.255.0 10.127.10.13
ip route 10.127.1.0 255.255.255.0 10.127.10.10
!
access-list 101 deny ip 10.127.2.0 0.0.0.255 any
access-list 101 deny ip 10.128.2.0 0.0.0.255 any
access-list 101 deny ip 10.127.10.12 0.0.0.3 any
access-list 101 deny ip 10.127.10.8 0.0.0.3 any
access-list 101 permit tcp 10.127.0.2 0.0.255.0 any eq telnet
access-list 101 deny tcp any any eq telnet
access-list 101 permit any any
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 8
═exec-timeout 0 0
═password cisco
═login
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end


Лабораторная работа: настройка очередей

Используемый стенд: стенд 1.

Используется конфигурация из лабораторной работы 1.3.1.
Упражнение: уменьшить скорость Frame Relay до 4800, запустить на PC команду
════════════ telnet адрес-соседнего-маршрутизатора 19
где соседний - по часовой стрелке, 19 - порт для сервиса chargen. Убедиться, что канал загружен и работать невозножно. Снять задачу и настроить алгоритм обработки очередей так, чтобы chargen никому не мешал.

Предварительные действия:

  1. запустить сервис chargen


    c2500x(config)#service tcp-small-servers

  2. уменьшить скорость Frame Relay до 4800 - на c2500b и c2522


    (config)#interface serial 0 (и 1)
    (config-if)#clock rate 4800

Действия по шагам (вместо n и m должны быть соответствующие числа):

  1. начать конфигурирование с терминала


    c2500x#configure terminal

  2. класть chargen в очередь с низким приоритетом


    c2500x(config)#priority-list 1 protocol ip low tcp chargen
    c2500x(config)#priority-list 1 queue-limit 20 40 60 5

  3. привязываем список к интерфейсам


    c2500x(config)#interface serial 0
    c2500x(config-if)#priority-group 1
    c2500x(config-if)#exit
    c2500x(config)#interface serial 1
    c2500x(config-if)#priority-group 1
    c2500x(config-if)#exit
    c2500x(config)#exit
    c2500x#

  4. наслаждаемся жизнью

Получившаяся конфигурация (show run):

Current configuration
!
version 11.2
no service udp-small-servers
service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
priority-group 1
═encapsulation frame-relay
═clockrate 4800
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
priority-group 1
═encapsulation frame-relay
═clockrate 4800
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
ip classless
ip route 10.128.0.1 255.255.255.255 10.127.10.13
ip route 10.128.1.1 255.255.255.255 10.127.10.10
ip route 10.127.10.0 255.255.255.252 10.127.10.13
ip route 10.127.10.0 255.255.255.252 10.127.10.10
ip route 10.127.0.0 255.255.255.0 10.127.10.13
ip route 10.127.1.0 255.255.255.0 10.127.10.10
!
priority-list 1 protocol ip low tcp chargen
priority-list 1 queue-limit 20 40 60 5
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 8
═exec-timeout 0 0
═password cisco
═login
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end


Лабораторная работа: протокол динамической маршрутизации EIGRP

Используемый стенд: стенд 1.
Используется конфигурация из лабораторной работы 1.3.1.
Упражнение 1: замена статической маршрутизации динамической EIGRP.
Предварительные действия: убрать статические маршруты.
Действия по шагам (вместо n и m должны быть соответствующие числа):

  1. включить отладку


    c2500x#debug ip eigrp

  2. начать конфигурирование с терминала


    c2500x#configure terminal

  3. отменяем статические маршруты
  4. задание протокола маршрутизации и AS


    c2500x(configure)# router eigrp 109

  5. отменяем автоматическое слияние маршрутов (у нас сеть класса A!)


    c2500x(configure-router)#═ no auto-summary

  6. заявляем местные сетки


    c2500x(configure-router)# network 10.0.0.0 0.255.255.255
    c2500x(configure-router)# redistribute static

  7. выходим из режима конфигурации


    c2500x(configure-router)# exit
    c2500x(configure)# exit

  8. смотрим получившуюся топологию


    c2500x#show ip eigrp topology

Получившаяся конфигурация (show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
ip classless
router eigrp 109
═ no auto-summary
═ network 10.0.0.0
═ redistribute static
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 8
═exec-timeout 0 0
═password cisco
═login
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end

Упражнение 2: "роняем" интерфейс межу c2500a и c2500b (делаем на c2500a: conf terminal;interface serial 0;shutdown). Наблюдаем за изменение топологии в таблицах EIGRP. Восстанавливаем нтерфейс и отмечаем время сходимости EIGRP.


Лабораторная работа: dial-up, DDR, AAA

Используемый стенд: стенд 2.

Последовательность шагов:

Получившаяся конфигурация c2500b(show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
username c1601b password cisco
username c2500b password cisco
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
interface Async1
═ip address 10.127.40.1 255.255.255.252
═encapsulation ppp
═async mode interactive
═ppp authentication chap
!
router eigrp 109
═ no auto-summary
═ network 10.0.0.0
═ redistribute static
═passive-interface Async1
!
ip route 10.127.40.0 255.255.255.252 10.127.40.2
ip route 10.127.41.0 255.255.255.0 10.127.40.2
ip route 10.127.40.2 Async1
ip classless
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 16
═exec-timeout 0 0
═password cisco
autoselect during-login
═autoselect ppp
═login
modem InOut
═transport input all
═stopbits 1
═speed 115200
═flowcontrol hardware
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end

Получившаяся конфигурация c1601b (show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c1601b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
username c1601b password cisco
username c2500b password cisco
ip subnet-zero
no ip domain-lookup
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
chat-script dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDP\T" TIMEOUT 60 CONNECT
!
interface Ethernet0
═ip address 10.127.41.1 255.255.255.0
!
interface Serial0
═physical-layer async
═ip address 10.127.40.2 255.255.255.252
═encapsulation ppp
═async mode interactive
═dialer in-band
═dialer-group 1
═dialer map ip 10.127.40.1 name c2500b modem-script dialout 13
═dialer idle-timeout 600
═ppp authentication chap
!
ip route 0.0.0.0 0.0.0.0 10.127.40.1
ip route 10.127.40.1 255.255.255.255 serial 0
ip classless
dialer-list 1 protocol ip permit
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1
═exec-timeout 0 0
═password cisco
═login
═modem inout
═stopbits 1
═speed 115200
═flowcontrol hardware
═transport input all
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end

Упражнение 2. сервер tacacs+

  1. маршрутизация должна быть во всей опорной сети
  2. tacacs.config


    default authorization = permit
    accounting file = /var/adm/acct
    key = cisco
    user = c1601a {
    ═══════ global = cleartext "cisco"
    ═══════ member = pppdefault
    }
    user = c1601b {
    ═══════ global = cleartext "cisco"
    ═══════ member = pppdefault
    }
    user = c1601b {
    ═══════ global = cleartext "cisco"
    ═══════ member = pppdefault
    }
    user = c2500a {
    ═══════ global = cleartext "cisco"
    ═══════ member = pppdefault
    }
    user = c2500b {
    ═══════ global = cleartext "cisco"
    ═══════ member = pppdefault
    }
    user = c2500c {
    ═══════ global = cleartext "cisco"
    ═══════ member = pppdefault
    }
    user = admin {
    ══ default service = permit
    ══ login = cleartext "cisco"
    ══ service = exec { priv-lvl=10 }
    }
    group = pppdefault {
    ═══════ service = exec { autocmd = "ppp /routing default" }
    ═══════ service = ppp protocol = ip {
    ═══════════════ routing = true
    ═══════ }
    }

  3. запуск:


    #/usr/local/bin/tac_plus -C tacacs.config

  4. изменения в конфигурации c2500x


    aaa new-model
    aaa authentication login default tacacs+ enable
    aaa authentication login line line
    aaa authentication login none none
    aaa authentication login local local
    aaa authentication ppp default if-needed none
    aaa authorization exec tacacs+ if-authenticated
    aaa authorization commands 1 tacacs+ if-authenticated
    aaa authorization commands 10 tacacs+ if-authenticated
    aaa authorization commands 15 tacacs+ if-authenticated
    aaa authorization network tacacs+ if-authenticated
    aaa accounting network stop-only tacacs+
    aaa accounting connection stop-only tacacs+
    aaa accounting system stop-only tacacs+
    tacacs-server host 10.127.0.2
    tacacs-server key cisco


Лабораторная работа: OSPF

Используемый стенд: стенд 2.
Используется конфигурация из лабораторной работы 3.1.4 (упражнение 1)
.
Упражнение 1: замена маршрутизации EIGRP на OSPF.
Предварительные действия: убрать маршрутизацию EIGRP.
Действия по шагам (вместо n и m должны быть соответствующие числа):

  1. включить отладку


    c2500x#debug ip ospf events

  2. начать конфигурирование с терминала


    c2500x#configure terminal

  3. отменяем═ маршрутизацию EIGRP


    c2500x(configure)# no router eigrp 109

  4. задание протокола маршрутизации


    c2500x(configure)# router ospf 63

  5. заявляем местные сетки


    c2500x(configure-router)# network 10.0.0.0 0.255.255.255 area 0
    c2500x(configure-router)# redistribute static

  6. объявляем соседей (т.к. у нас Frame Relay)


    neighbor 10.127.10.n
    neighbor 10.127.10.m

  7. не раздавать маршруты на сетку, подключенную по модему


    passive-interface async1

  8. выходим из режима конфигурации


    c2500x(configure-router)# exit
    c2500x(configure)# exit

  9. смотрим получившуюся топологию


    c2500x#show ip ospf database

Получившаяся конфигурация c2500b(show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
username c1601b password cisco
username c2500b password cisco
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
interface Async1
═ip address 10.127.40.1 255.255.255.252
═encapsulation ppp
═async mode interactive
═ppp authentication chap
!
router ospf 63
═ network 10.0.0.0 0.255.255.255 area 0
═ redistribute static
═ passive-interface Async1
═ neighbor 10.127.10.10
═ neighbor 10.127.10.13
!
ip route 10.127.40.0 255.255.255.252 10.127.40.2
ip route 10.127.41.0 255.255.255.0 10.127.40.2
ip route 10.127.40.2 Async1
ip classless
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 16
═exec-timeout 0 0
═password cisco
═autoselect during-login
═autoselect ppp
═login
═modem InOut
═transport input all
═stopbits 1
═speed 115200
═flowcontrol hardware
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end

Упражнение 2: "роняем" интерфейс межу c2500a и c2500b (делаем на c2500a: conf terminal;interface serial 0;shutdown). Наблюдаем за изменение топологии в таблицах OSPF. Восстанавливаем нтерфейс и отмечаем время сходимости OSPF.


Лабораторная работа: BGP4

Используемый стенд: стенд 3.

Используется конфигурация из лабораторной работы 3.1.4 (упражнение 1, EIGRP)
.
Упражнение 1: разбиение автономной системы на 3 (a - AS100, b - AS200, c - AS300)
Предварительные действия: убрать маршрутизацию EIGRP.
Действия по шагам (вместо n и m должны быть соответствующие числа):

  1. включить отладку


    c2500x#debug ip eigrp
    c2500x#debug ip bgp

  2. начать конфигурирование с терминала


    c2500x#configure terminal

  3. отменяем═ маршрутизацию EIGRP


    c2500x(configure)# no router eigrp 109
    маршрутизация EIGRP в пределах автономной системы
    c2500x(configure)# router eigrp n
    c2500x(configure-router)# no auto-summary
    c2500x(configure-router)# network 10.0.0.0
    c2500x(configure-router)# redistribute static
    c2500x(configure-router)# passive-interface Async1
    c2500x(configure-router)# exit

  4. запускаем BGP


    c2500x(configure)# router bgp n

  5. определяем соседей


    c2500x(configure-router)# neighbor 10.127.10.n remote-as m
    c2500x(configure-router)# neighbor 10.127.10.x remote-as y

  6. выходим


    c2500x(configure-router)#═ exit
    c2500x(configure)#═ exit

  7. смотрим соседей


    show ip bgp neighbor

Получившаяся конфигурация c2500b(show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
username c1601b password cisco
username c2500b password cisco
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
interface Async1
═ip address 10.127.40.1 255.255.255.252
═encapsulation ppp
═async mode interactive
═ppp authentication chap
!
router eigrp 200
═ no auto-summary
═ network 10.0.0.0
═ redistribute static
redistribute bgp 200
passive-interface Async1
!
router bgp 200
═ neighbor 10.127.10.10 remote-as 100
═ neighbor 10.127.10.13 remote-as 300
!
ip route 10.127.40.0 255.255.255.252 10.127.40.2
ip route 10.127.41.0 255.255.255.0 10.127.40.2
ip route 10.127.40.2 Async1
ip classless
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 16
═exec-timeout 0 0
═password cisco
═autoselect during-login
═autoselect ppp
═login
═modem InOut
═transport input all
═stopbits 1
═speed 115200
═flowcontrol hardware
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end

Упражнение 2: "роняем" интерфейс межу c2500a и c2500b (делаем на c2500a: conf terminal;interface serial 0;shutdown). Наблюдаем за изменение топологии в таблицах BGP. Восстанавливаем нтерфейс и отмечаем время сходимости BGP.


Лабораторная работа: policy routing

Используемый стенд: стенд 2.
Используется конфигурация из лабораторной работы 3.1.4 (упражнение 1, EIGRP)
.
Упражнение 1: переопределение routing policy так, чтобы пакеты из async наружу шли по правой ветке, а локальные пакеты по левой.
Предварительные действия:
Действия по шагам (вместо n и m должны быть соответствующие числа)

  1. определение access-list для доступа наружу


    c2500x(configure)# access-list 99 deny 10.127.x1.0 0.0.0.255
    c2500x(configure)# access-list 99 deny 10.127.x0.0 0.0.0.255
    c2500x(configure)# access-list 99 deny 10.128.y.1 0.0.0.1
    c2500x(configure)#═ access-list 99 permit any

  2. определение карт для правой и левой ветвей


    c2500x(configure)# route-map left permit
    c2500x(configure-route-map)# match ip address 99
    c2500x(configure-route-map)# set interface serial n
    c2500x(configure-route-map)# exit
    c2500x(configure)# route-map right permit
    c2500x(configure-route-map)# match ip address 99
    c2500x(configure-route-map)# set interface serial m
    c2500x(configure-route-map)# exit

  3. настройка интерфейса async1


    c2500x(configure)# interface async 1
    c2500x(configure-if)# ip policy route-map right
    c2500x(configure-if)# exit

  4. настройка local policy


    c2500x(configure)# ip local policy route-map left

═Получившаяся конфигурация c2500b(show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c2500b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
username c1601b password cisco
username c2500b password cisco
ip subnet-zero
no ip domain-lookup
frame-relay switching
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
!
interface Loopback0
═ip address 10.128.2.1 255.255.255.255
!
interface Ethernet0
═ip address 10.127.2.1 255.255.255.0
!
interface Serial0
═ip address 10.127.10.9 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.10 33 broadcast
═frame-relay interface-dlci 33
!
interface Serial1
═ip address 10.127.10.14 255.255.255.252
═encapsulation frame-relay
═clockrate 2000000
═frame-relay lmi-type ansi
═frame-relay intf-type dce
═frame-relay map ip 10.127.10.13 32 broadcast
═frame-relay interface-dlci 32
!
interface Async1
═ip address 10.127.40.1 255.255.255.252
═ip policy route-map right
═encapsulation ppp
═async mode interactive
═ppp authentication chap
!
router eigrp 109
═ no auto-summary
═ network 10.0.0.0
═ redistribute static
passive-interface Async1
!
ip route 10.127.40.0 255.255.255.252 10.127.40.2
ip route 10.127.41.0 255.255.255.0 10.127.40.2
ip route 10.127.40.2 Async1
ip classless
ip local policy route-map left
!
access-list 99 deny 10.127.41.0 0.0.0.255
access-list 99 deny 10.127.40.0 0.0.0.255
access-list 99 deny 10.128.2.1 0.0.0.1
access-list 99 permit any
!
route-map left permit
═ match ip address 99
═ set interface serial 0
!
route-map right permit
═ match ip address 99
═ set interface serial 1
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1 16
═exec-timeout 0 0
═password cisco
═autoselect during-login
═autoselect ppp
═login
═modem InOut
═transport input all
═stopbits 1
═speed 115200
═flowcontrol hardware
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end═


Лабораторная работа: туннели GRE

Используемый стенд: стенд 4.

Используется конфигурация из лабораторной работы 3.1.4 (упражнение 1, EIGRP)
.
Упражнение 1: организация туннелей, образующих кольцо между cisco 1601.
Действия по шагам (вместо n и m должны быть соответствующие числа):

  1. начать конфигурирование с терминала


    c1601x#configure terminal

  2. конфигурируем правый туннель


    c1601x(config)# interface tunnel 0

  3. определяем исходный интерфейс


    c1601x(config-if)# tunnel source serial 0

  4. определяем конечную точку туннеля


    c1601x(config-if)# tunnel destination 10.127.n0.2

  5. задаем═ IP адрес


    c1601x(config-if)# ip address 192.168.x.1

  6. выходим


    c1601x(config-if)# exit

  7. аналогично конфгурируем левый туннель


    c1601x(config)# interface tunnel 1
    c1601x(config-if)# tunnel source serial 0
    c1601x(config-if)# tunnel destination 10.127.m0.2
    c1601x(config-if)# ip address 192.168.y.2
    c1601x(config-if)# exit

Получившаяся конфигурация c1601b (show run):

Current configuration
!
version 11.2
no service udp-small-servers
no service tcp-small-servers
!
hostname c1601b
!
enable secret 5 $1$lAKC$LAxlg941G5KVmgaSZvT7u.
!
username c1601b password cisco
username c2500b password cisco
ip subnet-zero
no ip domain-lookup
clock timezone MSK 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
chat-script dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDP\T" TIMEOUT 60 CONNECT
!
interface Ethernet0
═ip address 10.127.41.1 255.255.255.0
!
interface Serial0
═physical-layer async
═ip address 10.127.40.2 255.255.255.252
═encapsulation ppp
═async mode interactive
═dialer in-band
═dialer-group 1
═dialer map ip 10.127.40.1 name c2500b modem-script dialout 13
═dialer idle-timeout 600
═ppp authentication chap
!
interface tunnel 0
═ tunnel source serial 0
═ tunnel destination 10.127.20.2
═ ip address 192.168.2.1
!
interface tunnel 1
═ tunnel source serial 0
═ tunnel destination 10.127.30.2
═ ip address 192.168.1.2
!
ip route 0.0.0.0 0.0.0.0 10.127.40.1
ip route 10.127.40.1 255.255.255.255 serial 0
ip classless
dialer-list 1 protocol ip permit
!
line con 0
═exec-timeout 0 0
═password cisco
═login
line 1
═exec-timeout 0 0
═password cisco
═login
═modem inout
═stopbits 1
═speed 115200
═flowcontrol hardware
═transport input all
!
line aux 0
═exec-timeout 0 0
═password cisco
═login
line vty 0 4
═exec-timeout 0 0
═password cisco
═login
!
end


Стенд 1

стенд 1


Стенд 2

стенд 2


Стенд 3

стенд 3


Стенд 4

стенд 4

@ Карта сайта News Автора!

Bog BOS: IOS: Лабораторные работы

Последние изменения:
2017.04.19: hard: АВР от APC

TopList
kaspersky work space security . маршрутка в финляндию от до адреса
Copyright © 1996-2017 Sergey E. Bogomolov; www.bog.pp.ru (КГБ знает все, даже то что у Вас на диске ;)